Your filesystem or build does not support posix ACLs, which s3fs requires

Error:
Your filesystem or build does not support posix ACLs, which s3fs requires. Try the mounting the filesystem with the 'acl' option."

 

Description:
I got this error while trying to run the provision step during the configuration of Samba4. I tried remounting my root file system with acl but still the provision step was throwing this error. Finally I got a workaround for this which I thought should share for others as well.

 

Solution:
Use extra argument along with the provision command as shown below
# samba-tool domain provision --use-interactive --use-ntvfs
Let me know your success and failures

4 thoughts on “Your filesystem or build does not support posix ACLs, which s3fs requires”

  1. Nice post. I like the way you start and then conclude your thoughts. Thanks for this information .I really appreciate your work, keep it up 🙂
    ACL tear

    Reply
  2. This is my first visit here. I found some really interesting stuff in your blog especially this discussion. Keep up the good work. This is my first visit here. I found some really interesting stuff in your blog especially this discussion. Keep up the good work.

    Reply

Leave a Comment

close button